This project has moved. For the latest updates, please go here.

where to find required DLLs in this site

Jul 2, 2013 at 3:51 AM
Hello,

I downloaded the source code and the latest installer. I ran the HydroDesktop_Installer_1.5_Recommended.exe and unzip the hydrodesktop-05b127e861a5.zip to a clean directory. I copied all the DLLs in the installed folder to source code folder. Load the project into vs2010, ran the HDReferenceFixer.exe as instructed. It did not fix the reference issue, spent couple hours fixing the reference. However few are still missing, eg microft.practice,xxxx, newton.jason, etc.

My question, where can I download a complete collection of DLLs from this site.

Thanks
Coordinator
Jul 3, 2013 at 5:58 PM
Hi can you explain further? Are you saying you cannot compile the source code?
Jul 4, 2013 at 2:04 AM
I got the following compiler 2 warnings

------ Build started: Project: HydroDesktop.MainApplication, Configuration: Debug Any CPU ------
C:\mapex4\hydrodesktop_05b127e861a5\Source\HydroDesktop.MainApplication\NavigationControl.cs(16,26): warning CS1591: Missing XML comment for publicly visible type or member 'HydroDesktop.MainApplication.NavigationControl'
C:\mapex4\hydrodesktop_05b127e861a5\Source\HydroDesktop.MainApplication\NavigationControl.Designer.cs(3,19): (Related location)
C:\mapex4\hydrodesktop_05b127e861a5\Source\HydroDesktop.MainApplication\NavigationControl.cs(19,16): warning CS1591: Missing XML comment for publicly visible type or member 'HydroDesktop.MainApplication.NavigationControl.NavigationControl(DotSpatial.Controls.AppManager)'

Compile complete -- 0 errors, 2 warnings
I ignored the warning and ran the app. It crashed with this error message
An unhandled exception of type 'System.IO.FileLoadException' occurred in Microsoft.VisualStudio.HostingProcess.Utilities.dll

Additional information: Could not load file or assembly 'DotSpatial.Controls, Version=1.5.0.0, Culture=neutral, PublicKeyToken=4d9e49339a7d240c' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)


which I believe was due to DLL version conflict.
Jul 4, 2013 at 4:17 PM
Hello,
Please take a look at the documentation:
https://hydrodesktop.codeplex.com/wikipage?title=Getting%20HydroDesktop

http://download-codeplex.sec.s-msft.com/Download?ProjectName=hydrodesktop&DownloadId=699619

The second tutorial shows step-by-step how to download the .zip file and build HydroDesktop from the source code. I have tested it in Visual Studio 2010 and Visual Studio 2012 Express.
Note that it is recommended to have the "NuGet Package Explorer" extension installed in your Visual Studio because HydroDesktop uses NuGet to get many of the external DLL's.

I don't recommend combining files from the 1.5 installer and the latest source zip file, because there are some DLL with version conflict that changed between the stable installer version and the latest source code.

Hope this helps,

Jiri Kadlec
Jul 5, 2013 at 2:31 AM
Thanks for the instructions.

I download the latest source code as a hydrodesktop-a5c7fd92c421.zip and unzip the files to a clean directory. It required vs2012 which I haven't installed on this bench. So I downloaded the older version hydrodesktop_a1c834ff57cd, unzip it to a clean directory. load the project into vs2010
then I used NuGet to fix the reference. It compiled OK. However, there is a problem with DotSpatial.Serialization when I tried to run MainApplication. It crashed on

public MainForm()
    {
        InitializeComponent();

        //It looks better if we Maximize the main window, 
        //but the Form.Owner property doesn't seem to do anything when running on Mono, so for now only maximize if on Windows.
        this.WindowState = FormWindowState.Maximized;
        appManager = new AppManager();
        appManager.Map = new Map(); <-------------------------------------------------
error message:


System.IO.FileLoadException: Could not load file or assembly 'DotSpatial.Serialization, Version=1.5.0.0, Culture=neutral, PublicKeyToken=441f200f827611e7' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
File name: 'DotSpatial.Serialization, Version=1.5.0.0, Culture=neutral, PublicKeyToken=441f200f827611e7'
at DotSpatial.Controls.MapFrame..ctor()
at DotSpatial.Controls.MapFrame..ctor(Control inParent, Extent inExtent)
at DotSpatial.Controls.Map.Configure()
at DotSpatial.Controls.Map..ctor()
at HydroDesktop.MainApplication.MainForm..ctor() in D:\hydro2\hydrodesktop_a1c834ff57cd\Source\HydroDesktop.MainApplication\MainForm.cs:line 31
at HydroDesktop.MainApplication.Program.Main(String[] args) in D:\hydro2\hydrodesktop_a1c834ff57cd\Source\HydroDesktop.MainApplication\Program.cs:line 44
at System.AppDomain._nExecuteAssembly(RuntimeAssembly assembly, String[] args)
at Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssembly()
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()

=== Pre-bind state information ===
LOG: User = asus-PC\asus
LOG: DisplayName = DotSpatial.Serialization, Version=1.5.0.0, Culture=neutral, PublicKeyToken=441f200f827611e7
(Fully-specified)
LOG: Appbase = file:///D:/hydro2/hydrodesktop_a1c834ff57cd/Binaries/
LOG: Initial PrivatePath = NULL

Calling assembly : DotSpatial.Data, Version=1.5.0.0, Culture=neutral, PublicKeyToken=c29dbf30e059ca9d.

LOG: This bind starts in default load context.
LOG: Using application configuration file: D:\hydro2\hydrodesktop_a1c834ff57cd\Binaries\HydroDesktop_1_6_dev.vshost.exe.Config
LOG: Using host configuration file:
LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework64\v4.0.30319\config\machine.config.
LOG: Post-policy reference: DotSpatial.Serialization, Version=1.5.0.0, Culture=neutral, PublicKeyToken=441f200f827611e7
LOG: Attempting download of new URL file:///D:/hydro2/hydrodesktop_a1c834ff57cd/Binaries/DotSpatial.Serialization.DLL.
WRN: Comparing the assembly name resulted in the mismatch: Major Version

ERR: Failed to complete setup of assembly (hr = 0x80131040). Probing terminated.

please advise how to fix this problem.

Thanks
Jul 5, 2013 at 4:27 AM
I assembled a vs2012 Express bench quickly and followed this instructions http://download-codeplex.sec.s-msft.com/Download?ProjectName=hydrodesktop&DownloadId=699619 , unzip the hydrodesktop-a5c7fd92c421.zip to a clean PC (win7 64bit), load the project into vs2012 Express, then in Solution Explorer right-click on hydrodesktop.sln, right-click on HydroDesktop.(34 project) and select "Restore", It downloaded the missing package. then I rebuilt all and got 34 succeeded. I then ran HydroDesktop_1_6_dev in \hydrodesktop_a5c7fd92c421\Binaries. It reported 2 skipping DotSatial.Plugins.menubar and 2 DotSpatial.Plugins.WebMap plus two other errors (total of 6). Anyway, it finally popped up only 2 items; EPA Tool and Map tool in the menu strip. What went wrong. please advise.

Thanks
Jul 7, 2013 at 7:53 AM
Hi,
I suspect that the problem could be some old files in your %appdata%/HydroDesktop directory.
Please check your %appdata% folder and delete any subfolders with the name HydroDesktop...

the %appdata% directory is like: C:\users\userName\AppData\Roaming\HydroDesktop_1_5...

I repeated the build of source code with 6c03525dbd12, and successfully built in Visual Studio 2010 (sp2). However I had to do "build solution" followed by "rebuild solution" and also "set as startup project" on HydroDesktop.MainApplication.

Jiri
Jul 7, 2013 at 2:42 PM
I erased the AppData\Roaming\HydroDesktop_xxx directory, downloaded again the latest, loaded the project into vs2012 Express, fixed the reference with NuGet. Press build, it generated 214 errors, pressed rebuild, again, it yields 214 errors. Can you tell me how to download 6c03525dbd12. Thanks.
Jul 7, 2013 at 10:04 PM
Hello jirikadlec2 & danames,

I finally solved this problem. I took out a clean PC, installed vs2012Express, unzip the hydrodesktop-a5c7fd92c421.zip to C:\, loaded the project into vs2012, fixed the reference with NuGet, built it and rebuit it,

it report two errors and 431 warning. I skipped the errors and warnings and switch to direcory C:\hydrodesktop_5412351d30c6\Binaries and ran HydroDesktop_1_6_dev.exe.

It took couple minutes to download the sample data and finally popped up with the welcome dialog. Finally got one Map6 type dotSpatial project done.

Thanks for your help.



lessons learned: I started with Map4x, then jumping among map6, dotspatial and hydrodesktop. the assembly of dotspatial must be confussed. lesson learned, better stick with one package and a clean PC. Map6 involves too many external packages, it is better, IMHO, start with hydrodesktop. get the feeling of dotspatial function behaviour then go back to dotspatial if you need to change/add the functions.
Jul 11, 2013 at 4:31 AM
I also have the chance to find what might be the action that corrupt the application.

I did not noticed that hydrodesktop downloaded two DLLs at first start-up.The downloaded DLLs are not compatible, hence the app threw up the error messages.